Karoshi MSX Community
12 de Diciembre de 2019, 03:59:18 am *
Bienvenido(a), Visitante. Por favor, ingresa o regístrate.

Ingresar con nombre de usuario, contraseña y duración de la sesión
Noticias:
 
   Inicio   Ayuda Buscar Ingresar Registrarse  
Páginas: [1]
  Imprimir  
Autor Tema: Problems with Waver2.0  (Leído 5599 veces)
0 Usuarios y 1 Visitante están viendo este tema.
mäsäxi
Karoshi Lover
***
Mensajes: 121



Email
« : 03 de Junio de 2006, 05:16:20 pm »

Hello!

Today I recorded a CD with tens of MSX .rom games (except one was .cas, waved using cas2wav).

Problem was that only one of them did run, and that was the cas2wav game.

I made one game cd some years ago already, using Waver2.0, so I guess I know what to do, I know the right volume level too for Cd-player. (thought not all did not work of course, even some of MSX-DEV games did not work!)


Ok, what I exactly did today was this:

waver gamename.rom -reset -mono -color number

and I used Spectravideo SVI-728 to load them. (I am not sure did I try SVI-728 some years ago, but my Philips MSX2)

Every game was Found:    and then at 0:14 minutes, screen went black. Just black (and it continued loading of course)

I wondered, as WAVER2.0 etc logos were NOT visible, screen was completely blank BLACK. no text.

just some games flashed (just once) quickly something white which probably (?) was part of WAVER 2.0 logo  (but that picture lasted just 0.01 seconds).

Games do load as normal, but they don´t run at all.

What can be wrong???

Is Waver2.0 NOT Spectravideo SVI-728 compatible?HuhHuhHuh (if it is so, then it is a problem as MOST finnish MSXs are Spectravideo 728s!!! and SVI-728s are my only working MSXs)
En línea
pitpan
Karoshi Forum's Guru
*******
Mensajes: 1812


« Respuesta #1 : 03 de Junio de 2006, 09:07:27 pm »

So bad. I don't know about the SVI-728 memory layout. If it has all the RAM in the same slot, it should work fine.

On the other side, I included in WAVeR v.2 an special loader for SVI-738 and -maybe- it detects SVI-728 as SVI-738 and makes a mess when trying to access the V9938 chip. Instead, try to use the following options:

WAVER -TINY game.rom

It will create a faster loader, with no logo and awful colour bars Wink

If it does not work, please send me a private message and I'll send you an alpha version of WAVeR v.3 Cheesy
En línea
mäsäxi
Karoshi Lover
***
Mensajes: 121



Email
« Respuesta #2 : 03 de Junio de 2006, 09:13:53 pm »

if I use -TINY option, how the screen will look then?

It is also totally blank as if there is no logo and awful colour bars?
En línea
pitpan
Karoshi Forum's Guru
*******
Mensajes: 1812


« Respuesta #3 : 03 de Junio de 2006, 09:43:12 pm »

It should not clean the screen, therefore you'll see the BLOAD"... command and the colour bars. Or at least that is what it should happen.
En línea
pitpan
Karoshi Forum's Guru
*******
Mensajes: 1812


« Respuesta #4 : 03 de Junio de 2006, 09:48:13 pm »

Make one more test:

Do not use the -RESET switch and convert the game using the -TINY switch. Then, after the loading finishes (you should hear the motor relay clicking), reset the computer. But, does the SVI-728 have a reset button?

If not, just use the WAVeR v.1, that is still available for download.
En línea
Páginas: [1]
  Imprimir  
 
Ir a:  

Impulsado por MySQL Impulsado por PHP Powered by SMF 1.1.21 | SMF © 2013, Simple Machines XHTML 1.0 válido! CSS válido!